Why is my test on Chrome v91 and above bumping Selenium version to 3.141 from 2.53?

Chrome 91 and above are known to be incompatible with Selenium 2, so we are bumping your tests to the next available Selenium version which can run your tests successfully. In general, we recommend updating to the newest versions of Selenium that your suite can support - it means you get access to the latest and greatest from your framework of choice, along with the best performance and stability. If your tests are breaking because of this automatic change, please contact us at support@browserstack.com.
Need more help? Contact Support