Appium Version Deprecation Policy

We periodically look at the Appium versions supported on BrowserStack and identify old Appium versions (typically released more than 2 years ago) and those with minimal usage. Since such older Appium versions may no longer be relevant for our customers they may be considered for deprecation. In such a scenario, we will be doing prompt customer communication and provide appropriate time period for the customers to update their scripts.

Once an Appium version goes into deprecated state, users will not be able to run BrowserStack sessions on it. We strongly recommend customers to use latest Appium versions supported on BrowserStack as they provide better stability and performance.

For the current list of Appium versions, please refer "browserstack.appium_version" capability under "Test configuration capabilities" section on App Automate Capability Builder page