Skip to main content

Handle Device not getting detected issues

Issue

Connected mobile devices are not being detected by BrowserStack AppPerformance desktop app.

Cause

  • Mobile device does not have debugging or developer mode enabled
  • Mobile Device has unsupported OS version

Resolution

  • For connected mobile devices, ensure you have debugging enabled
  • For an iOS 16 device, Apple mandates developer mode to be enabled. Check the steps below to enable Developer Mode
  • Currently, we support mobile devices with Android >=10.0 & iOS >=13.0 OS versions.

Enable Developer Mode in iOS 16 devices

Need some help?

If you need additional help, contact us

We're sorry to hear that. Please share your feedback so we can do better

Contact our Support team for immediate help while we work on improving our docs.

We're continuously improving our docs. We'd love to know what you liked






Thank you for your valuable feedback

Is this page helping you?

Yes
No

We're sorry to hear that. Please share your feedback so we can do better

Contact our Support team for immediate help while we work on improving our docs.

We're continuously improving our docs. We'd love to know what you liked






Thank you for your valuable feedback!

Talk to an Expert
Download Copy